Exchange 2007 Does Not Support Outlook 2016

Posted by Theresa Hietpas

Oct 12, 2015 3:49:21 PM

Microsoft Outlook 2016If your business is currently running Exchange Server 2007, be aware that the new Outlook 2016 that was recently released is not supported.

Historically, Microsoft Outlook is supported on three version of Exchange Servers. With the latest upgrade to Outlook 2016, those version are: Exchange 2016, 2013 & 2010. Therefore, Exchange server 2007 is no longer accessible using Outlook 2016. 

If you are using Exchange Server 2007 you should not upgrade to Outlook 2016.  If you have already tried to upgrade and are having issues you need to re-install your previous version.  If you are replacing computers you may need to purchase volume licenses of Office 2016 so you have downgrade rights to install a previous version.

River Run is actively alerting our clients and community of the problem. If you would like some assistance in upgrading your Exchange Server 2007 to a newer version or re-installing previous versions of Office in your business, please give us a call! 

Topics: Exchange Server

Most Popular Posts

Subscribe

* indicates required

Posts by Topic

see all